To get the best out of your Celayix platform, please refer below to our system requirements below.


System Requirements

Browser

The latest versions of Google Chrome and Firefox are the only browsers that we support. Other browsers such as Internet Explorer, Edge, Safari, Opera are not supported and will give unpredictable results. If you do not have either Chrome or Firefox, they can be downloaded for free:

Computer

Windows and Mac only. As a result of the system requirements for the browsers, Windows must be version 10 or later, and Mac OS must be 10.11 or later. (OS requirements will change over time as the Citrix and browser requirements change.)

At least 4 GB memory (more is better)

At least 2 CPUs (more is better)

Note: Chromebook is not supported.

Mobile devices

Team Xpress and Time Xpress are available for iOS and Android.

Apple 1OS must be version 10.x or later.

Android must be version 7.0 or later.

Application platforms

Each Celayix component is designed to run on a specific platform. In the table below, the module can be accessed only on the designated platform.

Module

User role

Computer browser

Phone app / browser

Tablet app / browser

Citrix on computer

Schedule Xpress

Scheduler

YES

Team Xpress

Employee

YES

YES

YES

Time Xpress

Field Supervisor

YES

YES

eTime Xpress

Admin / Payroll

YES

For more information, please Contact Support now!

Did this answer your question?